[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

apt complains about the wrong dependency problems



I tried to install galeon from pandora/~robot101/mozilla (inserting the
appropriate line into /etc/apt/sources.list) and got:

# apt-get install galeon
Reading Package Lists... Done
Building Dependency Tree... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.

Since you only requested a single operation it is extremely likely that
the package is simply not installable and a bug report against
that package should be filed.
The following information may help to resolve the situation:

Sorry, but the following packages have unmet dependencies:
  galeon: Depends: liboaf0 (>= 0.6.5) but 0.6.5-5 is to be installed
          Depends: liborbit0 (>= 0.5.8) but 0.5.8-2 is to be installed
          Depends: libxml1 but 1:1.8.13-1 is to be installed
          Depends: oaf (>= 0.6.5) but 0.6.5-5 is to be installed
  libgnome-dev:E: Sorry, broken packages

which of course looks completely bogus, given that the "to be installed" are
already on the system and of the shown version.

 Getting the .deb directly and
trying installing with dpkg gives:

 galeon depends on libart2 (>= 1.2.13-7); however:
  Version of libart2 on system is 1.2.13-6.
 galeon depends on libgnome32 (>= 1.2.13-7); however:
  Version of libgnome32 on system is 1.2.13-6.
 galeon depends on libgnomesupport0 (>= 1.2.13-7); however:
  Version of libgnomesupport0 on system is 1.2.13-6.
 galeon depends on libgnomeui32 (>= 1.2.13-7); however:
  Version of libgnomeui32 on system is 1.2.13-6.
 galeon depends on libgnorba27 (>= 1.2.13-7); however:
  Version of libgnorba27 on system is 1.2.13-6.
 galeon depends on mozilla-browser (>= 2:0.9.1); however:
  Package mozilla-browser is not installed.

looking much more useful. When I tried to install libgnome32 it complained:

# apt-get install libgnomeui32    
Reading Package Lists... Done
Building Dependency Tree... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.

Since you only requested a single operation it is extremely likely that
the package is simply not installable and a bug report against
that package should be filed.
The following information may help to resolve the situation:

Sorry, but the following packages have unmet dependencies:
  libgnome-dev:E: Sorry, broken packages

But apt-get install libgnome-dev succeded and installed the right libraries.

Something must still be wrong with apt's conflict resolution scheme.



Nils

--
                                     ______
                                    (Muuuhh)
Global Village Sau  ==>        ^..^ |/¯¯¯¯¯
(Kann Fremdsprache) ==>        (oo)

Attachment: pgpijfTZUJVYd.pgp
Description: PGP signature


Reply to: