[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Bug#95801: won't let me upgrade perl from stable to unstable

reassign 95801 perl-base

To restate this bug report in simple terms:

It is simply not possible to install perl-base[1] from unstable as it
conflicts with perl-5.004-base[2] which is a required package in
stable, and no longer exists in unstable[3].

>>>>> "Jason" == Jason Gunthorpe <jgg@debian.org> writes:

    Jason> <sigh> Please read exactly what I am saying, I already
    Jason> discussed this problem with Brendan before I replied to
    Jason> you. The fact that dist-upgrade works makes this not-a-bug.

    Jason> By asking it to remove some packages, that implicitly
    Jason> implies others need to be upgraded, which implies that some
    Jason> perl packages need to be removed.  You asked for that, you
    Jason> have to accept that. You may suggest it not remove
    Jason> perl-5.004 base by also listing that on the command line,
    Jason> but you may find it removes more packages that you'd like
    Jason> it to.

No. I tried that but it did not work. I said why in my previous post:
perl-5.004-base does not exist anymore[3]!

snoopy:nfsroot:/# apt-get install perl-base perl-5.004-base
Reading Package Lists...
Building Dependency Tree...
Sorry, perl-5.004-base is already the newest version.
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

Sorry, but the following packages have unmet dependencies:
  perl-base: Conflicts: perl-5.004-base but 5.004.05-6 is to be installed
E: Sorry, broken packages

It is simply not possible to install perl-base[1] from unstable as it
conflicts with perl-5.004-base[2] which is a required package in
stable, and no longer exists in unstable[3].

    >> It is a bug. It means that I cannot upgrade from stable to
    >> unstable.

    Jason> No, it means you can't do this specific situation you asked
    Jason> for, you said dist-upgrade works, so you can in fact
    Jason> upgrade to unstable!
I don't recall saying that. If so, I did, I am sorry, I must have been
confused at the time (or maybe the archive has changed since then, or
maybe I just missed the message at the bottom of the verbose
output). dist-upgrade does not work. IT CANNOT WORK! If you don't
understand why it cannot work, please reread my previous message

As for proof (seeing as you won't take my word for it):

snoopy:nfsroot:/# apt-get dist-upgrade                     
Reading Package Lists...
Building Dependency Tree...
The following packages will be REMOVED:
  guile1.3 libgimp1.1 libgnomeprint6 libguile6 libguile6-slib mkhybrid
  perl-5.004 perl-5.004-base perl-5.004-suid snes9x-server task-gnome-apps
  task-gnome-desktop task-gnome-games task-gnome-net task-x-window-system-core
  xbase-clients xf86setup xmanpages xpm4g 
The following NEW packages will be installed:
  asclock-themes blas1 bonobo cdrdao console-common cpp-2.95 debconf-utils
  defoma dia-common dialog g++-2.95 gcc-2.95 gconf gnocatan-client
  gnocatan-data gnocatan-help gnome-gnotski guile-common guile1.4
  guile1.4-slib icewm-common ifupdown imagemagick ipchains klogd lapack
  libbonobo2 libbz2-1.0 libcap1 libcupsys2 libdb3 libdps1 libefs1 libfreetype6
  libgconf11 libgimp1.2 libgmp3 libgnome-vfs0 libgnomeprint15 libguile9
  libhtml-tagset-perl libltdl0 libmagick5 libnetpbm9 liboaf0 libperl5.6
  libpspell2 libregexx0 libscrollkeeper0 libstdc++2.10-glibc2.2 libungif4g
  libwmf0 libwraster2 libxaw-dev libxaw6 libxaw7 libxml2 mp3info net-tools
  netkit-inetd netkit-ping netpbm oaf perl perl-5.6 perl-doc perl-modules
  portmap scrollkeeper sox tcl8.3 tk8.3 xlibs xlibs-dev xserver-common-v3
  xserver-xfree86 xutils 
The following packages have been kept back
  gnumeric pan rwho sawfish sawfish-gnome ssh-askpass-gnome xscreensaver 
The following packages will be DOWNGRADED
  dia diskless-image-simple gcd gdm gmc gnome-media gnome-pim
  gnome-pim-conduits gphoto grip libgnome-pilot0 libungif3g libunicode0
  mc-common nvi rep-gtk rep-gtk-gnome xmms 
WARNING: The following essential packages will be removed
This should NOT be done unless you know exactly what you are doing!
  perl-5.004-base (due to perl-base) 
346 packages upgraded, 77 newly installed, 18 downgraded, 19 to remove and 8  not upgraded.
Need to get 168MB of archives. After unpacking 83.0MB will be used.
You are about to do something potentially harmful
To continue type in the phrase 'Yes, do as I say!'

    Jason> Read it. Carefully. Your output has no relevence what so
    Jason> ever for 2 reasons, the first being that it is not the
    Jason> installed package, and the second being that it is dpkg
    Jason> 'avail' output which is not used by APT.

It has the highest version number???? I always run dselect update???

Please, I do know what I am doing. However, perhaps this might
convince you:

Notes: Package [1] from unstable:

[520] [snoopy:unstable:bam] ~ >apt-cache show perl-base 
Package: perl-base
Essential: yes
Priority: required
Section: base
Installed-Size: 2520
Maintainer: Brendan O'Dea <bod@debian.org>
Architecture: i386
Source: perl
Version: 5.6.0-21
Replaces: perl-5.005-base (<< 6), perl-5.6-base (<< 6), perl-modules (<< 5.6.0-19)
Provides: perl5-base, perlapi-5.005, perlapi-5.6.0, data-dumper
Depends: libc6 (>= 2.2.1-2)
Suggests: perl
Conflicts: perl-5.004-base, perl-5.005-base (<< 6), perl-5.6-base (<< 6), data-dumper
Filename: pool/main/p/perl/perl-base_5.6.0-21_i386.deb
Size: 839538
MD5sum: e60552c2c1dceda92c22b6273be953c3
Description: The Pathologically Eclectic Rubbish Lister.
 A scripting language with delusions of full language-hood, Perl is used
 in many system scripts and utilities.
 This is a stripped down Perl with only essential libraries.  To make
 full use of Perl, you'll want to install the `perl', `perl-modules' and
 optionally `perl-doc' packages which supplement this one.

Same package, same problem.

 Package [2] from stable:

snoopy:nfsroot:/# dpkg -s perl-5.004-base
Package: perl-5.004-base
Status: install ok installed
Priority: extra
Section: base
Installed-Size: 870
Maintainer: Darren Stalder <torin@daft.com>
Source: perl-5.004
Version: 5.004.05-6
Replaces: perl-base
Provides: perl5-base
Pre-Depends: libc6 (>= 2.1.2), libgdbmg1
Suggests: perl-5.004
Conflicts: perl (<< 5.004.04-2)
Description: The Pathologically Eclectic Rubbish Lister
 A scripting language with delusions of full language-hood, Perl is used
 in many system scripts and utilities.
 This is a stripped down Perl with only essential libraries.  To make
 full use of Perl, you'll want to install the perl-5.004 package
 which supplements this one.


 Package [3] from unstable:

[521] [snoopy:unstable:bam] ~ >apt-cache show perl-5.004-base

doesn't exist,



    Jason> Why are you arguing with me? Instead of taking the time to

Agreed. Why are you arguing with me? Instead of asking me for more
details to explain the problem, which you don't seem to understand,
you are constantly accusing me of being wrong. However, thank-you for
not closing the bug this time.

(you could check this stuff yourself too. eg.
says much the same thing).

    Jason> reopen the bug, you should have reassgned it to a perl
    Jason> package, or accept that it is Not-A-Bug. I have already
    Jason> provided sufficient explanation in the first message to
    Jason> show that it is not an APT bug.

    Jason> Since I am not convinced this is even a bug at all, I am
    Jason> not going to foist it on anyone else. If you still belive
    Jason> something is wrong then it is up to you to talk to Brendan
    Jason> yourself - that is why I closed the bug, why you reopened
    Jason> it in spite of my explaination of why it is not an apt bug
    Jason> is beyond me...

I am afraid you have not convinced me you have read my bug report
properly, especially when you say "dist-upgrade" will work, when I
have given details in my last message as why it cannot work. Also you
assume that the output from dpkg --print-avail is incorrect. I hope I
have proved that it is correct, and yes, I do know what I am doing.

However, I will reassign the bug to perl-base, seeing that is the
package which seems to have started this mess. If the maintainers
disagree with the problem, then they can argue with you. I have spent
too long on this already.
Brian May <bam@snoopy.apana.org.au>

Reply to: