[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: A problem with Build-Depends

On Fri, 30 Mar 2001, Dale E Martin wrote:
> (I'm not on this list, please Cc: dmartin@cliftonlabs.com replies.)

> Lintian is saying to me:
> ~/debian> lintian cdparanoia_3a9.8-1.dsc 
> E: cdparanoia source: package-uses-debhelper-but-lacks-build-depends

debhelper is not build-essential (please install the build-essential package
to read the list of build-essential packages), so you have to declare a
build dependency on it.  Also, if you use dh_testversion, declare that
version dependency as well (using a versioned build dependence).

> b) Are my Build-Depends simply silly?  (I.e. is it safe to assume you've
> got gcc and libc6-dev installed if you're building a package?)

gcc and libc6-dev are considered build-essential, so you need not
build-depends on them.

  "One disk to rule them all, One disk to find them. One disk to bring
  them all and in the darkness grind them. In the Land of Redmond
  where the shadows lie." -- The Silicon Valley Tarot
  Henrique Holschuh

Attachment: pgp2BCkYsCt8S.pgp
Description: PGP signature

Reply to: