[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

apt-get update etc broken

Normally I'd post this to -user but I think  I saw somthing about this earlier this week on -devel. I checked the web archives, but the latest -devel posts were from March 6.

Running unstable. Recent removal of helix gnoem packages and reinstall debian packages. This seemed to go ok. Then, did an apt-get update, upgrade on Monday. Everything seemed ok, but I tried to apt-get update yesterday and got:

debian:/home/me# apt-get update
0% [Working]/usr/lib/apt/methods/ftp: error while loading shared libraries: /lib/libnss_db.so.2: symbol __nss_db_open, version GLIBC_2.1 not defined in file libdb.so.3 with link time reference
E: Method ftp has died unexpectedly!
E: Tried to dequeue a fetching object

Not sure what program provides libdb.so.3, or if that is the problem, or what to do next to fix apt.

Any help appreciated much in advance!

michael heyes

 /~\ ASCII ribbon |
 \ / campaign     |
  X  against      |
 / \ HTML mail    |
Reply to: