[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: lintian whining about app-defaults file

phil@bolthole.com wrote:
>On Fri, Mar 16, 2001 at 11:08:01AM +0000, Colin Watson wrote:
>> phil@bolthole.com wrote:
>> >c) Something else [debhelper?] that allows folks to keep using the nice,
>> >   clean Imake syntax of
>> >       InstallAppDefaults(AppFile)
>> >   and not have to worry about absolute paths at all.
>> Use debhelper v3, which handles conffiles in /etc for you?
>I'm not up to speed on debhelper v3. Are you suggesting:
>a) stop using Imake and let debhelper install the app-defaults file


>b) use debhelper v3 to build the package, because it automagically
>  populates conffiles for you


>I see problems with both of the first two:
>  a)  -- well, gee, why bother even having Imake in debian
>  b) -- its not a matter of what *I* use, it's a matter of what the
>        autobuilders use.

Er. You realize that you can have versioned build-dependencies, don't
you? Build-Depends: debhelper (>= 3.0.0) and the autobuilders will use
that too. In any case, with DH_COMPAT=3, I believe older versions of
debhelper will throw an error on the grounds that you clearly wanted a
newer one.

Colin Watson                                     [cjw44@flatline.org.uk]

Reply to: