[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Perl essential ?

Glenn, et al,

There's perlcc, also. I advise checking it out. Be sure to `ldd' it; if it
links against some perl .so or another, there may be a problem, but at
least you don't have to include the interpreter in Essential in this case.



PGP/GPG Fingerprint:
  EFD1 AC6C 7ED5 E453 C367  AC7A B474 16E0 758D 7ED9

Version: 3.12
GCS/CM>CC/IT d- s:+ a16 C++(++++)>$ UL++++>$ P--- L++>++$ E+ W+(-) N+ o? K? w---() 
!O !M !V PS+(++)>+ PE-(--) Y+>+ PGP t+>++ !5 X-- R>++ tv(+) b+(++) DI(+) D++ 
G>+++ e--> h! !r y>+++ 

On Fri, 2 Mar 2001, Glenn McGrath wrote:

> >From my count there are 24 essential binaries, totalling 6550kB of
> linux-i386 debs.
> Perl-base is one of them at 840kB, ~13% of total essential size.
> I just unpacked all the essential binaries except perl, did "grep perl
> -r *" and found the following depend on perl
> debianutils: mkboot
> dpkg: mksplit
> dpkg: setup
> dpkg: install
> dpkg: update-rc.d
> dpkg: update-alternatives
> dpkg: install-info
> dpkg: dpkg-devert
> dpkg: dpkg-stateoverride
> dpkg: cleanup-info
> util-linux: checkdupexe
> find . -name "*pm" didnt find anything.
> (any other test i should have done ?)
> Would it be a good long term goal to remove perl from Esssential and
> rewrite these scripts for a posix compliant shell or in c.
> Im dont know much about perl or these scripts, but im good with c and ok
> with sh scripts, if i did work on non-perl replacements would they be
> welcome ?
> Glenn
> -- 
> To UNSUBSCRIBE, email to debian-devel-request@lists.debian.org
> with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org

Reply to: