[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: WARNING! (was: Re: New Perl Packages Released)

On Tue, Feb 20, 2001 at 10:00:06AM +0900, Olaf Meeuwissen wrote:
> > polya:~ # apt-get dist-upgrade
> > Reading Package Lists... Done
> > Building Dependency Tree... Done
> > [...]
> > 56 packages upgraded, 3 newly installed, 93 to remove and 2 not upgraded.
> > Need to get 47.3MB of archives. After unpacking 109MB will be freed.
> > Do you want to continue? [Y/n] n
> > Abort.
> > polya:~ #
> > 
> > But interestingly, if I use dselect with the APT backend, everything
> > goes OK.  I'm not sure where the descrepancy lies.  (dselect wants to
> > install perl, but apt-get dist-upgrade on its own doesn't.)
> I've had something similar happen to me a while back which turned out
> to be caused by dselect looking at Recommends: and Suggests: as well,
> whereas apt only looked at Depends: and Pre-Depends:
> Any chance you are seeing the same behaviour?

Could be.  If someone tells me what to look for, I'll do so.  But this
definitely needs fixing sometime real soon.



         Julian Gilbey, Dept of Maths, Queen Mary, Univ. of London
       Debian GNU/Linux Developer,  see http://people.debian.org/~jdg
  Donate free food to the world's hungry: see http://www.thehungersite.com/

Reply to: