[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: WARNING! (was: Re: New Perl Packages Released)

On Fri, Feb 16, 2001 at 09:15:18AM -0500, Daniel Jacobowitz wrote:
> On Sat, Feb 17, 2001 at 01:12:08AM +1100, Brendan O'Dea wrote:
> > I'm still not clear which arch you're using, but:

I'm using i386.

> > >Package perl-base has broken dep on perl-5.004-base
> > >  Considering perl-5.004-base 0 as a solution to perl-base 5133
> > >Fixing perl-base via remove of perl-5.004-base
> > >Package perl has broken dep on perl-5.004
> > >  Considering perl-5.004 1 as a solution to perl 53
> > 
> > would suggest that it's either not i386, or your Packages file(s) are
> > broken.  perl-base doesn't depend on perl-5.004-base.  Quite the
> > opposite in fact, it conflicts.
> That's a conflict in apt-speak.  Note that it resolved the "broken dep"
> by removing perl-5.004-base.  The perl-5.004 bit confuses me though.

The problem is still present.  I could fix it manually, but I'd prefer
to see if we can find the problem.  Is there any way I can get more
useful information out of apt about what it thinks it's doing?  Is
there any more information I can provide to anyone to help elucidate
this mystery?



         Julian Gilbey, Dept of Maths, Queen Mary, Univ. of London
       Debian GNU/Linux Developer,  see http://people.debian.org/~jdg
  Donate free food to the world's hungry: see http://www.thehungersite.com/

Reply to: