[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: WARNING! (was: Re: New Perl Packages Released)

On Thu, Feb 15, 2001 at 08:35:12PM -0800, Stephen Zander wrote:
>>>>>> "bod" == Brendan O'Dea <bod@debian.org> writes:
>    bod> Because they were not intended to do so, and demonstrably do
>    bod> not.
>While a dist-upgrade may not, a dselect-upgrade on sparc (~ 5min ago)
>certainly tried to.  Returning to dist-upgrade removed the problem :)

I'd be curious to see what that was.  Note that dselect-upgrade is only
goin to work if you actually enter dselect's selection screen and allow
it to mark packages for addition/removal.

Note also that one of the reasons that the transition packages exist is
such that the postrm scripts of the old packages aren't run during the
upgrade as they attempt to run update-alternatives when perl doesn't

So if you wish to remove them, do so *after* the upgrade completes.

Brendan O'Dea                                        bod@compusol.com.au
Compusol Pty. Limited                  (NSW, Australia)  +61 2 9810 3633

Reply to: