[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: PRE Version numbers

On Sun, Jan 14, 2001 at 09:55:15PM +1100, Hamish Moffatt wrote:
> On Sun, Jan 14, 2001 at 09:36:46AM +0100, Tom Cato Amundsen wrote:
> > jabber is not a debian native package, so  the problem that
> > 1.4-0pre1 > 1.4 is not a big problem. You first real version should
> > be 1.4-1, not 1.4
> BUT, the upstream source will probably change if it is a pre-release
> 1.4 (rather than just a pre-release Debian package), and the new 
> dinstall does not allow the upstream source to change between Debian
> revisions (quite rightly IMHO).
Sorry about that, of course upstream source will change between
pre-releases. Is it ok to use epochs for this?

1:1.4pre1-1 < 1:1.4pre1-2 < 1:1.4pre2-1 < 2:1.4-1

One other solution is:

1.4pre1-1 < 1.4pre2-1 < 1.4-final-1 < 1.4-final-2 < 1.5-1

This mean, the version number for the final release will
be "1.4-final". The ugly part is that 1.4 < 1.4pre and
1.4 < 1.4-final, so remember to never make a 1.4 release.

Someone with more clue should comment on this.
Tom Cato Amundsen <tca@gnu.org>
GNU Solfege - free eartraining, http://www.gnu.org/software/solfege/

Reply to: