[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Obsolete software in /usr/local

On Fri, Jan 05, 2001 at 05:30:58PM +0000, Dale Scheetz wrote:
> I run several "ancient" programs, by housing them in /usr/local/bin, with
> the libraries they need (which are no longer provided in Debian) situated
> in /usr/local/lib. In previous systems, right up to potato, this worked
> fine.
> I just finished building a woody system, so I can get my packages up to
> date, and all these programs stopped working because the needed library
> was not found. If I copy the /usr/local/lib contents to /lib everything
> works fine, suggesting that ldconfig no longer traverses /usr/local/lib
> for the libraries found there. Is this what is going on ... why ... and
> what do I do to correct the problem?

It would seem to come down to this entry in /usr/share/doc/ldso/README.gz

Changes in version 1.9.2:

        Removed /usr/local/lib from the default /etc/ld.so.conf
        for Debian (Bug#8181).

        Changed ldconfig to be 64-bit clean (H.J. Lu).

You simply need to add /usr/local/lib to /etc/ld.so.conf and run
ldconfig and all will be back to the way it was before.

    nSLUG       http://www.nslug.ns.ca      synrg@sanctuary.nslug.ns.ca
    Debian      http://www.debian.org       synrg@debian.org
[ pgp key fingerprint = 7F DA 09 4B BA 2C 0D E0  1B B1 31 ED C6 A9 39 4F ]
[ gpg key fingerprint = 395C F3A4 35D3 D247 1387  2D9E 5A94 F3CA 0B27 13C8 ]

Reply to: