[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Bug#77600: im: imput, impwagent seem to require perl 5.003, don't work with 5.004, 5.005

>>>>> In <Pine.GSO.4.21.0011210252340.3790-100000@sample.ifp.uiuc.edu> 
>>>>>	"Kevin M. Squire" <k-squire@uiuc.edu> wrote:

>> > >> Package: im
>> > >> Version: 1:140-1
>> > >> Severity: important

>> >From /bin/imput, line 41:

 Is this type?
 im package does not contain /bin/imput,

$ dpkg -c im_140-1.deb  | grep imput
lrwxrwxrwx root/root         0 2000-02-29 13:16:39 ./usr/share/man/man1/imput.1.gz -> ../man7/undocumented.7.gz
-rw-r--r-- root/root      9583 2000-02-29 13:15:27 ./usr/share/doc/im/manual/ja/imput.ujis.gz
-rwxr-xr-x root/root     58172 2000-02-29 13:15:16 ./usr/bin/imput

 If /bin/imput exist, it is not from im.deb package (and is not im
 package's bug).

>> >From /bin/imput, line 41:
>>   require 5.003;

 This `require 5.003' means `require perl 5.003 or higher' like this

$ perl -v

This is perl, version 5.005_03 built for i386-linux

Copyright 1987-1999, Larry Wall

Perl may be copied only under the terms of either the Artistic License or the
GNU General Public License, which may be found in the Perl 5.0 source kit.

Complete documentation for Perl, including FAQ lists, should be found on
this system using `man perl' or `perldoc perl'.  If you have access to the
Internet, point your browser at http://www.perl.com/, the Perl Home Page.

$ perl -e 'require 5.003; print "ok\n"'
$ perl -e 'require 5.005; print "ok\n"'
$ perl -e 'require 5.006; print "ok\n"'
Perl 5.006 required--this is only version 5.00503, stopped at -e line 1.

 <ishikawa@linux.or.jp>, <ishikawa@debian.org>, <ishikawa@redhat.com>

Reply to: