[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: HOWTO: Join the 6bone!

On Sat, 23 Sep 2000, Henrique M Holschuh wrote:

> On Sat, 23 Sep 2000, Jason Gunthorpe wrote:
> [...]
> I just wanted to call your attention to a possible catch.
> Someone wrote in another thread that insmod ipv6.o may fail if RTNETLINK is
> compiled in. The work around is to compile ipv6 into the kernel, as opposed
> as a module.

Are you referring to my message, or someone else's?  Here's where I got
the idea that it may not have been the best of ideas to build the IPv6
support as a module:

In a message date 1 Sep 2000, William F. Maton wrote in response to 
Dariush Pietrzak:

> On Sat, 2 Sep 2000, Dariush Pietrzak wrote:

> > Hmm, 
> >  Do I need to recompile kernel on my machine to use ipv6?

> Yup.

> > debian comes with ipv6 as module, maybe that's not enough?

> Compile it into kernel, not as a module.  Then try IPv6 again.

After I read that, in the archived messages from the debian-ipv6 mailing
list, I just assumed that there was something that caused the module to
not work.  This is what I get when I run "modprobe ipv6" after turning
"netlink_dev" on in the networking options and rebooting:

Using /lib/modules/2.2.17/ipv6/ipv6.o
/lib/modules/2.2.17/ipv6/ipv6.o: unresolved symbol rtnetlink_links
/lib/modules/2.2.17/ipv6/ipv6.o: unresolved symbol __rta_fill
/lib/modules/2.2.17/ipv6/ipv6.o: unresolved symbol rtnl

Now, a difference between my configuration and Mr. Gunthorpe's is that I'm
set to load netlink_dev as a module.  However, it doesn't matter if I load
netlink_dev or not, I still get the unresolved symbols.  I am now
attempting to build netlink_dev into the kernel to see if that changes

No, it doesn't.  In fact, it appears as if netlink_dev isn't even used by
ip.  It turns out the difficulty that I had been having with ipv6 being
built as a module is entirely due to the fact that I wasn't rebuilding the
kernels properly.
Jonathan Guthrie (jguthrie@brokersys.com)
Brokersys  +281-580-3358   http://www.brokersys.com/
12703 Veterans Memorial #106, Houston, TX  77014, USA

Reply to: