[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Upcoming changes with glibc and db2

Well, with glibc 2.1.93 on the way into woody, you will all need to note
that db/db2 are not in glibc anymore. For now, libdb2 will be supplying
the symlinks required to keep packages compiled against glibc's db/db2
from breaking, and  libc6 will depend on this new libdb2 package (same as
before, but with symlinks).

Now, some applications will report:

  foo: /usr/lib/libdb.so.[23]: no version information available (required by foo)

This is mostly harmless, but means the program needs to be recompiled
agains the new libdb2-dev. Yes, you will have to start adding
Build-Depends for libdb2-dev for applications that need it. I don't like
adding extra deps to glibc, so you all will have to fix this yourselves.

Be fore-warned, I will periodically check packages that have library links
to libdb.so.[23] (the old glibc db libraries) and report bugs on them for
recompilation. By the time woody releases, I want to remove the libdb2
dependency from libc6. It's only there for now to keep things from
breaking on running systems.


/  Ben Collins  --  ...on that fantastic voyage...  --  Debian GNU/Linux   \
`  bcollins@debian.org  --  bcollins@openldap.org  --  bcollins@linux.com  '

To UNSUBSCRIBE, email to debian-devel-request@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org

Reply to: