[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: New glibc 2.1.92 test packages (i386, powerpc, sparc)

> > Does that by itself get a segmentation fault? Also, are you building as
> > root, or under fakeroot? If under fakeroot, then don't, it has issues
> > building glibc. If the above works ok, and you are building as root, try:
> I use sbuild, which uses sudo (basically it calls dpkg-buildpackage -rsudo I
> think). This counts as building as root? Or should I run the whole build as
> root, this would be a new requirement for glibc.

That suffices, yes. Just that libfakeroot causes problems during the
execution of the newly compiled programs (forces loading of
/lib/libc.so.6, which causes some conflicts). I should put something in
the debian/rules to force this issue (check for the env var that fakeroot


/  Ben Collins  --  ...on that fantastic voyage...  --  Debian GNU/Linux   \
`  bcollins@debian.org  --  bcollins@openldap.org  --  bcollins@linux.com  '

Reply to: