[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Installation using 2.2.16-2000-07-14 boot disks

On Mon, 7 Aug 2000, Dale Scheetz wrote:

> Hardware:
> 486/66 Intel
> 500 Meg IDE /dev/hda
> 200 Meg IDE /dev/hdb
> CDROM Creative Labs SBPCD

Memory? (see below!)

> Boot process:
> 5 floppies:
> rescue
> root
> driver-1
> driver-2
> driver-3
> Once the CDROM driver was installed I got the base system off the CD.
> Errors during the boot process:
> VM: do_try_to_free_pages failed for modconf

Not enough Virtual Memory?

> When it happens, and it doesn't happen every boot up, this message

Hmmm... might be the timing between the various running processes, which is
influenced by the access speed of the harddisk which has a random component.

> repeates enough to fill the screen several times. Eventually the boot
> process completes.
> Whether or not I see them during boot, they continue to appear from time
> to time, all through the installation and continue during normal
> opperations. Under these circumstances the typical message is:
> VM: do_try_to_free_pages failed for kswapd
> Once I get to that point in the install, I set up a 100 meg swap
> partition, and everything seems to be correct. However, I continue to get
> the error messages on a fairly steady, if sparse, schedule. (mayby once in
> several hours opperation)

IIRC it's possible to alloc un-swappable memory, or at least big chunks of
memory that can't be swapped while the program is running (i.e. !=sleeping). 
This would mean you can get low on memory even with much unused swap space. 

> Stage 2 Installation:
> Upon reboot, the installation process continues. In several places I get
> the following errors splattered on the screen:
> use of unititialized value at /usr/lib/perl5/ConfModule.pm line 45
> use of unititialized value at /usr/lib/perl5/Open3.pm line 188

Seen that too, but doesn't seem harmful. Just some "bad programming" ;-)

> While these errors don't seem to cause any real problems for the install,
> they are a bit ugly.
> X Installation:
> The CD I'm using for testing only has -9 on it for the XFree stuff. I see
> that -10 is available in the archives, so my problems may already be
> fixed.
> This is much better than it was several releases ago, an the task packages
> are a big help, but there are still some flaws.
> anXious, while being a nice easy way to do this, fails on non-PCI bus
> cards, and does so in a very non-graceful way.
> The screen after the hardware check is full of unintelligable language. It
> says something about server installed, but is missing the name of the
> server. There is an error message about non-PCI cards mixed in with the
> rest of the dialog, and the final statement says "graphics card detected",

Yeah. "The cannot detect your hardware card has been detected" ;-)
Use SuperProbe.

> when it hasn't been. Of course the config file thus created is
> non-functional.
> I tried XF86Setup, but the first time it failed because I told it to use
> the existing config file for the defaults. The resulting message was:
> _X11TransSocketUNIXConnect: Can't connect: errno=111
> Seems I should know what this means, having seen it before, but I can
> never remember what causes this error.

Simple: the X server is not running. But of course you knew that already ;-)

> Restarting SF86Setup without the "broken" config file for defaults, at
> least brings up the dialog screen for normal configuration. However, the
> COM1 connected serial mouse is not configured. When I set the values in
> the mouse config screen correctly for my serial mouse, and press apply, I
> still get no mouse actions.

Running GPM? It's way broken with the 2.2 kernel. Stop GPM and try again or
use /dev/gpmdata.

> Maybe I should just get the latest packages and see how they work?
> One of the things that this experience brough home to me is just how slow
> a 486/66 IDE drive really is! Yes, the CDROM is slow as well, but the
> drive light on the CDROM only comes on every few minutes, while the hard
> disk light stays lit almost all the time.

Swapping. I installed on a 486 with 16 meg memory, but the packages list of 3
CD's is _far_ to big for dpkg to fit it in the memory, so it's swapping
continuously. Emptying the /v/l/d/available file works much much better!
(I'm using apt-get, of course)

> The base system took a full half hour to transfer from the CD onto the
> hard disk. This seems very long even considering the slowness of the
> machine. I have to wonder if those VM: messages might not be related to
> the drive slowness somehow...

  Anne Bezemer

Reply to: