[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Release-critical Bugreport for June 9, 2000

On Fri, 9 Jun 2000, Christopher C. Chimelis wrote:

> > Package: opie-client (debian/main)
> > Maintainer: Michael Stone <mstone@debian.org>
> >   64740  opie-client should depend on libc6.1 not libc6 on Alpha
> > [STRATEGY] Adrian Bunk made an NMU, at http://www.fs.tum.de/~bunk/nmus.html
> FYI, this should be easily fixed by changing:
> 	Depends: libc6
> to:
> 	Depends: libc6 | libc6.1

The better solution used in my NMU is:

Depends: ${shlibs:Depends}

This solution does calculate a versioned dependency on libc6, too.


A "No" uttered from deepest conviction is better and greater than a
"Yes" merely uttered to please, or what is worse, to avoid trouble.
                -- Mahatma Ghandi

Reply to: