[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Sound support on potato

Thomas Hood wrote:
> There's some confusion to be cleared up here.
> >    o esd: this program depends on alsa
> No it doesn't.  For esd to run there have to be some sound drivers
> installed but these drivers can be either OSS or ALSA (or any other).

yep. esound -> oss, esound-alsa -> alsa right? I was confused because
of dselect's stupid UI. I think it has a wrong idea about "suggests"

> > IMHO such programs shouldn't depend on alsa, or any specific sound
> > driver. That should be flexible. All gnome packages depend on alsa
> No they do not.  GNOME requires esd if sound is enabled in the
> control-center, but esd will work with either OSS or ALSA.

OK, I mean I got that but I was quite annoyed at the fact that
I haven't able to use my card's line input.

> One problem I do see with GNOME, however, is that when sound
> is enabled and esd isn't running, a GNOME application pauses
> each time it tries and fails to play a sound.  Something needs
> to be done about this.

Can't this be fixed in esd?

> >    o alsa: still we have the 0.4.x versions in potato. And may I remind you
> > that 0.4.x versions are obsolete?
> Yes they are obsolete.  However, in order to release Debian it is
> necessary to freeze versions at some point so that everything can
> be made to work together.  It would be nice to upgrade to 0.5.x,
> but this would break some sound packages because the ALSA API
> and libraries changed from 0.4.x to 0.5.x.

Aren't they backward compatible in most cases?

> > Is it a custom to make obsolete software to go in the "stable"
> > version?
> For the reasons given above, yes.
> > 0.5.x are the stable upstream releases. There
> > might be a few things that will work better with the old versions, so either
> >      i) throw those packages away, since most of the stuff works well with oss
> >      emulation. if they don't work with the new modules, who cares?
> So just toss out all packages that work with 0.4.x but not (yet) with
> 0.5.x ?  Some people might want to use those packages.

Both 0.4.x and 0.5.x modules are made available, but the newer versions are
recommended. Are they both available in woody?

> >      ii) if they require old versions of the libs, those libs could be maintained
> >      in oldlibs section.
> True.  But what makes more sense is upgrade all ALSA-related sound packages
> to the 0.5.x level.  When this is done, people can upgrade their whole
> sound system to 0.5.x.  But this ypgrade hasn't been completed yet, SFAIK.

Yes, but holding back a device driver because a not-up-to-date program isn't
working well isn't quite clever. I think most of the programs work all right,
so what's the point here?
> >    o "other" sound drivers: I think it's a good idea to make other kernel sound
> > drivers as module packages as they are available. For instance, there's a not-very-good
> > SB Live! driver from creative.
> I am using alsa-modules-2.2.15_0.5.8a-1+2.2.15-1 downloaded from
> http://incoming.debian.org *the same day* that the 0.5.8a ALSA
> drivers were released.  If there are other sound drivers you'd
> like packaged up, perhaps alien can be of help; or perhaps you'll
> become a maintainer.

If that creative thing would work, I would package it surely. But it's
a bit problematic. It doesn't seem to be release quality yet.

Ahem, so there are binary up-to-date alsa packages in woody? That's very nice.
I had to install alsa manually by making a bogus debian package for the 0.5.7

> > The problems with the alsa packages are, IMHO, quite urgent and should be fixed
> > some time. I don't think that the maintainer reads the bug reports at all, anyway.
> What makes you think that?

I don't think I've received any replies to the bug reports I filed. But if they are
all done on woody, it's ok.

> > For the argument that "These packages are stable, and many prudent packages use them",
> > I would like to suggest taking the author's opinion on this subject. I'm quite confident
> > that the author will suggest the latest stable releases for distribution. (version
> > 0.5.7)
> Once one takes into account the problem of actually getting a release
> out the door, one understands that the release can't include the very
> latest version of every software package.

Okay, but shouldn't we be taking the author's idea of stable release? So we use
kernel 2.2.15 because it's stable, but not 2.2.3 (obsolete) or 2.3.x (unstable)
> Having said that, I'll agree with you that Debian's releases come
> too slowly.  Many people think that something needs to change.

Package pools?
> > In addition, there seem to be some sound applications which could be included in potato.
> > Perhaps those could be made into one of those mythical "potato updates" that people have
> > been talking about.
> Which applications do you have in mind?

Some mixer proggys, some wave editors, synths. I mean, stuff you would use for making
music. For instance, ecasound isn't in debian right? I didn't even run it, but there
seems to be some programs worth packaging.


 ++++-+++-+++-++-++-++--+---+----+----- ---  --  -  - 
 +  Eray "exa" Ozkural                   .      .   .  . . .
 +  CS, Bilkent University, Ankara             ^  .  o   .      .
 |  mail: erayo@cs.bilkent.edu.tr                .  ^  .   .

Reply to: