[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

remote printing on potato

Hello there,

Already posted this question to debian-user list, but got no reply in
reasonable amount of time, so I thought I'd mail this to
debian-devel because it might perhaps be considered a bug in the
Recently I installed potato on my desktop. I have a laptop running slink
connected to the desktop via plip. The laptop is setup in a way that it
can print with lpd via a remote-printer entry in /etc/printcap to the
printer attached to the desktop (the desktop is also running lpd). Oh by
the way, I have the lpr, not the lprng packages installed on both
As long as I was using slink on the desktop, this worked wonderful. I had
an entry in /etc/hosts.lpd for my laptop-host. Now I tried to set things
up with potato (new install, no upgrade). And I couldn't find the
/etc/hosts.lpd file, so I created one. 
I tried to print to the desktop from the laptop and nothing happened.
So I looked into /var/spool/lpd/remote/status and found something like the
Waiting for spool to be enabled on desktophostname
But lpd was running on the desktop, and the plip line was up (other
services could be run without problems).
So I did:
lprm -Prp from the laptop (rp is the name of the remote printer entry)
and got:
desktophostname: your host does not have lineprinter access.
So I looked at the manpage of lpd (on the potato system), if something has
changed concerning access control, but it said, that it should work with
an entry in /etc/hosts.lpd
I then looked at the Debian.changelog.gz in /usr/doc/lpd (or
/usr/share/doc/lpd, as you like it), and found in the most recent entry a
line similar to this one:
+ tighten host authentication
So my questions are:
What exactly has been changed in the authentication, and where's the
documentation about remote host access to the line printer (apart from
the manpage, which doesn't seem to have changed much from slink to
And finally, (but I probably might be able to solve this one by myself, if
I get an answer to the first question) how do I get things to work?

Reply to: