[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Bug#63066: xvncviewer uses several Conflicts:+Replaces: which depends on a fixed dpkg

Josip Rodin <joy@cibalia.gkvk.hr> wrote:
> Package: xvncviewer
> Version: 3.3.3-10
> Severity: important
> Hi,
> The xvncviewer package has this:
> Conflicts: vnc, vnc-doc
> Replaces: vnc, vnc-doc
> In order to have dpkg upgrade that correctly, you have to add
> Pre-Depends: dpkg (>= 1.6.8)
> to the control file, since only versions including and after 1.6.8 have
> support for multiple Conflicts: and Replaces:.

Okay but according to policy:

2.3.4. Dependencies

     Every package has to specify the dependency information about other
     packages, that are required for the first to work correctly.

     For example, for any shared libraries required by dynamically-linked
     executable binary in a package a dependency entry has to be provided.

     It is not necessary for other packages to declare any dependencies
     they have on other packages which are marked `Essential' (see below).

     Sometimes, a package requires another package to be installed _and_
     configured before it can be installed.  In this case, you'll have to
     specify a `Pre-Depends' entry for the package.

     You must not specify a `Pre-Depends' entry for a package before this
     has been discussed on the `debian-devel' mailing list and a consensus
     about doing that has been reached.

I have to ask debian-devel, so what do you think? Is there a consensus that
this is the right thing to do?

Don't worry  --  shop.

Reply to: