slink->potato upgrade fail
In IRC channel #debianjp (talked in Japanese), we are reported
that upgrading from slink to potato will fail with:
libc6-dev: Dedpends: libc6 (= 2.0.7....) but 2.1.3-8 is installed
According to our investigation, this is because
egcc and g++ installed
Depends: libc6, g++ (>= 2.91.66), g++ (<< 2.91.67)
Depends: libc6, binutils (>= 2.9.1), libstdc++2.9-dev (>= 2.91.66)
Depends: libstdc++2.9 (>= 2.91.66), libc6-dev, g++ (>= 2.91.58)
then, these will require libstdc++2.9-dev.
Since pototo doesn't have libstdc++2.9-dev (but libstdc++2.10-dev),
however, apt-get will insist with libstdc++2.9-dev because no egcc
in potato. (I don't know why apt-get do this way)
It might be apt-get bug, but it could be fixed by changing dependency
of gcc package in potato to conflicts with egcc *without* versioned
dependency, that is,
Depends: libc6 (>= 2.1.2), cpp (>= 1:2.95.2-4), cpp (<< 1:2.95.3), binutils (>= 220.127.116.11.12)
Suggests: gcc-doc (>= 1:2.95.2-4)
Conflicts: libc5-dev, egcc
Provides: egcc, c-compiler
In our case, upgrading works fine once egcc is removed, so it is one easy
solution of this problem. And we have egcc anymore, so I think it is no
necessary to conflicts with egcc with versioned.
Any other good solution?