[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: UPS setup problems (apcuspd and genpower)

On Fri, Mar 31, 2000 at 02:04:58PM +0200, Agustín Martín Domingo wrote:
> "Thomas R. Shemanske" wrote:
> > 
> > At *no* time are any messages printed to the terminal windows (to
> > indicate power failure, warning logouts imminent, power resumed, etc).
> > So I am rather confused.  apcupsd collects valid data but
> > /usr/sbin/powersc doesn't act on it.
> > 
> Do not know about apcupsd. I am using apcd to monitor my APC
> Back-UPS650. Remember that if you try it you will need the other cable,
> (the smart one, I think is the 0025)
> > I have also tried genpower (/sbin/genpowerd /dev/ttyS0 apc-pnp) (which
> > is the correct type for the APC Cable 940-0095A.  The /etc/upsstatus
> > *always* says OK even if the plug is pulled.
> I suppose your model is a 650PnP since that behavior is different from
> mine. From what I have read you need to switch the unit from smart to
> simple mode to be able to use the simple monitoring mode genpower
> handles, and genpower do not do that. I think the software delivered
> with the unit is required for that.
> If your model is a 650SI, it is a smart only UPS, and genpower is not an
> appropiate choice. That is the model I have and it took me a lot of time
> until I discovered that. However, it detected power failure, but did not
> switch off the UPS after a time.
That seems to be the common problem. Mine is a smart-ups 420 (european model),
with a 0024c cable. I ran slink at the time I got it. I tried the few
ups monitor tools available in slink, but these didn't shut down the system
(they did detect power failure). I tried the newer versions (and greater
choice) from potato, compiled from package source, but the same there. Since
these weren't packages run on their regular system, I didn't file bugs.
I got the powerchute tools from the apc site, and that works really fine.

I probably should give the debian (not closed source) packages another try I
guess, now that I am running potato anyway, but considering these messages,
I hardly think it is worth the effort.



PS. my cable type shouldn't be a problem, at least apcupsd says it can work
with it.

Reply to: