[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

upgrade nightmare from slink to potato


After having worked with potato at the office for a few weeks now, I decided
to upgrade my slink box at home. I pulled the CD images made by Andreas
Jellinghaus and started. I had apt-0.3.13 on my slink box, so I decided to
use the apt-cdrom way.

apt-cdrom for all four discs went fine, apt-get dist-upgrade failed. After a
lot of forcing with dpkg --force-depends, I had the new glibc, the new ldso
and new perl-5.004 installed and apt-get dist-upgrade agreed to work.

The next minutes were filled with literally thousands of CD changes.
Occasionally, a package was installed and/or configured and everything
seemed to work well. However, I wouldn't expect some non-expert user to live
with these millions of disc changes. There has some optimizing to be done
before the release. Also, I got zillions of locale error messages and messages
saying that /usr/doc/<packagename> was not empty and therefore couldn't be

Then, suddenly, apt-get asked me to insert CD 1 from _slink_. Yes, slink. It
wouldn't continue otherwise. So I inserted slink CD 1. In the meantime, apt
was updated to 0.3.18, so my slink disc wasn't recognized any more. I decided
to Ctrl-C out of the apt-get process and did a apt-cdrom add on slink CD 1.

That must have been a mistake, because from now, apt-get wouldn't continue.
It gets right to "111 packages not fully installed or removed" and stops
there. apt-get is set to state "sleeping" and my system load is 0.0. I let
it wait for an hour but it didn't look like it intended to wake up.

apt-get -s -f install gives me a list of things to do, starting with "Inst
jed-common, Conf libnet-perl, Conf dpkg-perl, Conf tetex-base, Conf
zlib1g...", and ending with "Conf vncserver, Conf whiptail, Conf
xfonts-100dpi, Conf xfonts-75dpi, Conf xfonts-base, Conf xfonts-scalable,
Conf anacron, Conf cracklib2, Conf file-rc" before returning me to a shell
prompt. apt-get -f install would stop at "111 packages not fully installed
or removed".

I then decided to dpkg --install jed-common manually because that was the
first thing apt intended to do. This brought apt back on track.

Same thing happened again later when I had to manually dpkg --install gzip,
hostname, update, ncurses-bin and multiple other packages.

make and latex2html complain that there are old files in /usr/doc/<package>
and offer to copy them over. latex2html fails to do so:
cp: /usr/doc/latex2html/copyright' and /usr/share/doc/latex2html/..
/latex2html/copyright' are the same file.

Then, I reached a situation where apt-get would again stop with "4 packages
not fully installed or removed.". But this time, manually doing the first
few operations that apt-get -s dist-upgrade mentions first didn't help. I
I tried doing that about ten times, but it didn't help.

I now have a system that doesn't know its cursor keys, that complains about
locale errors all the time and can't be logged in to via the network.

Does anybody have any ideas to solve this situation?


Reply to: