[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Upgrade to potato impossible?

I tried upgrading a slink box to potato on thuesday, but I got an
E: Internal Error, Couldn't configure a pre-depend
That was a freshly installed slink r4 + xfree 3.3.6 and october gnome

Today I tried upgrading my own slink box. I added potato sources to my
apt sources list and did apt-get update, and then tried to install a new
apt and dpkg before doing the upgrade, but it didn't work:

sh-2.01# apt-get install -s apt dpkg
Reading Package Lists... Done
Building Dependency Tree... Done
The following extra packages will be installed:
  libncurses5 libgtk1.2 g++ libstdc++2.10 locales cpp gcc gpc
  libgtk1.2-dev libc6-dev gobjc libstdc++2.10-dev libc6 binutils ldso 
The following packages will be REMOVED:
  timezones libstdc++2.9-dev egcc 
The following NEW packages will be installed:
  libncurses5 libstdc++2.10 libstdc++2.10-dev 
15 packages upgraded, 3 newly installed, 3 to remove and 598 not
Inst ldso
Conf ldso
Remv timezones
Inst locales
Inst libgtk1.2-dev []
Inst libgtk1.2 []
Inst cpp [gcc ]
Inst binutils [gcc ]
Inst gcc []
E: Internal Error, Couldn't configure a pre-depend

That's not really helpfull...
I also tried apt-get dist-upgrade -s but got the same problem.

What is going wrong here? am I the only one who has this? 
I can send my list of installed packages if that helps.

Wat voor een paperclip geldt, geldt in wezen ook voor een server.
- Compaq over de nieuwste ProLiant servers

Reply to: