[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: potato missing /dev's

>On 26-Jan-00, 11:08 (CST), Kenneth Scharf
>> I compiled the kernel with support for ftape.  Only
>> there are no devices in /dev for ftape (/dev/qft0,
>> /dev/nqft0, /dev/mt0, /dev/nmt0 etc....)  The
>> /sbin/MAKEDEV script seems like it should build
>> but I tried running it without anything happening. 

>> What am I missing....?

>You need to give an argument to MAKEDEV to specify
>what devices you
>want built -- browse the script for hints (I'd tell
>you, but I don't
>know offhand.) The other absolutely key thing is that
I think the argument is -d or -v, the script looks
like it wants to build EVERYTHING (I don't know bash
that well, but it does look a little like perl...)

>you *must* 'cd
>/dev' before running it. For some totally unexplained
>reason, it builds
>devices in the current directory. I suppose there is
>some traditional
>reason why this is so, but I'm very tempted to report
>a fatal bug
>against it.

>If you've already run it, you might want to look
>arround your disks for
>stray device files. (find / -type c |grep -v "/dev")

Did that, didn't find any.

What I did do was to clip the makedev() routine out of
MAKEDEV into it's own script, and feed it the
arguments for qft0 and qft1 (after cd'ing into /dev)
and thereby built these two devices.  THEN taper
worked (with zftape) and I could also tar ...-f
/dev/qft0.  But why weren't the devices for ftape
built by default when I installed potato?  It seems to
come with everything else but the kitchen sink. (even
USB stuff!!!)  Comeon, don't tell me people don't use
ftape.  (you can get qic80 drives REAL CHEAP these
days.  True they don't hold that much...).


Amateur Radio, when all else fails!


Debian Gnu Linux, Live Free or .....

Do You Yahoo!?
Talk to your friends online with Yahoo! Messenger.

Reply to: