[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: errors during recent dist-upgrades

On Mon, Nov 08, 1999 at 03:49:52PM +1100, Hamish Moffatt wrote:

> > Are you sure you are seeing out of order configuration? That would be
> > really bad.. Maybe capture some script output.
> Too late, it's all done now. I definately saw a lot of packages
> fail to configure because xpm4g was not yet configured; similar with
> gcc and binutils, IIRC. dpkg is

I had a similar problem when installing potato (locally mirrored and a few 
weeks behind) onto a new computer. I got a lot of errors from dpkg saying 
"dependency problem prevent configuration of foo" because "foo depends on bar
which is not configured yet".

I was sure it is a dpkg problem but realized it must be apt's fault - running 
dpkg --configure -a worked like a charm and configured everything.

It might be of interest that I installed about 300 packages. Maybe we are 
hitting the limit for command line length here? I mean apt-get calling 

dpkg --configure <pkgname>*200 

might overflow the commandline I guess...


Reply to: