[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Binary packages with outdated sources



Hello world,

I've started playing around with verifying binary<->source relationships
the past few days, and I've come across a number of packages that appear
to have newer versions of the binaries than the source. The main reason
for this seems to be arch specific NMUs by the porters, but there are
a few seemingly normal maintainer uploads too.

It'd be nice if this could be minimised somewhat. Ideally, it'd be nice
if it were reduced to just uploads of the -x.x.1 variety (arch specific
recompiles). Even more ideally, it'd be nice if the Packages.gz entries
for these included a `source: foo (y-x.x)' so it's completely clear that
these are just recompiles.

Anyway, the list of affected packages for i386, m68k, alpha, sparc and
powerpc follows. FWIW, etc.

no source at all: (9 packages)
----------------
        (presumably leftovers that the ftp-admins missed removing?)

    sparc:
        kernel-source-2.2.9 (2.2.0-2), binary: kernel-image-2.2.9-sun4u

    powerpc:
        mh-ja (6.8.4-jp.3.02-4)
        workplace (1.0.a4.1-1)
        libtricks (0.2-5)
        sorcerer (1.0)
        gtksamba (1:0.3.2pl1-4), binary: gtksamba-gnome, gtksamba
        libcanlock (0.0.980924-1), binary: libcanlock0{,-dev}
        gmp2 (2.0.2-6.2), binary: gmp2{,-dev}
        libjpeg (6a-11), binary: libjpegg{6a,-dev}

upstream/maintainer changes: (7 packages)
---------------------------
        (the maintainers of these have been cc'ed)

    clanlib0 0.1.16-2: i386 has 0.1.18-1   
    rosegarden 2.1-3: i386 has 2.1-4       
    pan 0.5.2-1: i386 has 0.5.2-2          
    htp 1.10-2: i386 1.10-3                

    mac-fdisk 0.1-1: m68k has 0.1-2

    lde 2.4-5pre1.1: m68k, sparc, powerpc have 2.4-5.1      
    clips 6.0-2: alpha, sparc have 6.0-3.1

normal nmus: (43 packages)
-----------

    yagirc 19981014-1: alpha has 19981014-1.1
    libsrp-dev 1.1-1: alpha has 1.1-1.1
    xloadimage 4.1-3: alpha has 4.1-3.1
    iglooftp 0.6.1-1: alpha has 0.6.1-1.1
    uqwk 1.8-2: alpha has 1.8-2.1

    tclmidi 3.1-4: sparc has 3.1-4.1
    bwbasic 2.20pl2-3: sparc has 2.20pl2-3.1
    netdiag 0.6-3.2: sparc has 0.6-3.2.1
    frad 0.20-2: sparc has 0.20-2.1
    zile 1.0a5-3: sparc has 1.0a5-3.1
    egcs1.0 1.0.3a-2: sparc has 1.0.3a-2.1
    xmgr 4.1.2-2: sparc has 4.1.2-2.1
    cern-httpd 3.0A-2: sparc has 3.0A-2.1
    ruari-diff 0.15: sparc has 0.15-0.1
    uqwk 1.8-2: sparc has 1.8-2.1
    tk4.2 4.2p2-7: sparc has 4.2p2-7.1
    xview 3.2p1.4-5: sparc has 3.2p1.4-5.1
    umich-ldap 3.3-3: sparc has 3.3-3.1
    libg++27 2.7.2.1-14.4: sparc has 2.7.2.1-14.4.2
    xaw95 1.1-4.4: sparc has 1.1-4.4.1
    ifcico-cm 3.0alpha.4.0-1: sparc has 3.0alpha.4.0-1.1
    cti-ifhp 2.2.8-1: sparc has 2.2.8-1.1
    tcl7.6 7.6p2-8: sparc has 7.6p2-8.1
    gmp 2.0.2-3: sparc has 2.0.2-3.1
    macgate 1.14-3: sparc has 1.14-3.1
    xbattle 5.4.1-7: sparc has 5.4.1-7.1

    icon 9.3-1.1: powerpc has 9.3-1.2
    r-cran 0.63.0-1: powerpc has 0.63.0-1.1
    clanlib0 0.1.16-2: powerpc has 0.1.16-2.1
    xmotd 1.14b3-1.2: powerpc has 1.14b3-1.3
    acm 4.7-6: powerpc has 4.7-6.1
    smb-nat 10-2: powerpc has 10-2.1
    jgraph 83-10: powerpc has 83-10.1
    xzip 1.70-3: powerpc has 1.70-3.1
    xfree86-1 3.3.5-1: powerpc has 3.3.5-1.1
    radiusd-livingston 1.16.1-0.1: powerpc has 1.16.1-0.2
    xvier 1.0-5: powerpc has 1.0-5.1
    gtkfontsel 1.1-3: powerpc has 1.1-3.0.1
    timeoutd 1.5-2: powerpc has 1.5-2.1
    xgammon 0.98a-3: powerpc has 0.98a-3.1
    libdbi-perl 1.12-1: powerpc has 1.12-1.1
    xinput 1.2-3: powerpc has 1.2-3.1

recompiles:  (31 packages)
----------

    gimp 1.0.4-2: i386 has 1.0.4-2.0.1

    tclx76 7.6.0-3: m68k has 7.6.0-3.0.1
    tk4.2 4.2p2-7: m68k has 4.2p2-7.0.1
    gstep-core 0.5.5.990625-1: m68k 0.5.5.990625-1.0.1
    gcc 2.95.2-0pre2: m68k has 1:2.95.2-0pre2.0.2

    perl-tk 1:800.014-1.1: alpha has 1:800.014-1.1.1
    guitar 0.1.4-4: alpha has 0.1.4-4.0.1
    gnome-think 0.1.2-1: alpha has 0.1.2-1.0.1
    eperl 2.2.14-0.5: alpha has 2.2.14-0.5.1
    balsa 0.4.9-1.1.1: alpha has 0.4.9-1.1.2
    libterm-readkey-perl 2.14-1: alphas has 2.14-1.0.1
    enlightenment-conf 0.15-1: alpha has 0.15-1.0.1
    libmime-base64-perl 2.11-2: alpha has 2.11-2.0.1
    enlightenment 0.15.5-1: alpha has 0.15.5-1.0.1
    gide 0.1.0.19990402-1: alpha has 0.1.0.19990402-1.0.1
    gnome-guile 0.99.0.cvs.19990627-1: alpha has 0.99.0.cvs.19990627-1.0.1
    dds2tar 2.4.21-2: alpha has 2.4.21-2.0.1
    bock 0.20: alpha has 0.20.0.1
    gnome-network 1.0.2-1: alpha has 1.0.2-1.0.1
    xcircuit 2.0a6-3: alpha has 2.0a6-3.0.1
    xaw95 1.1-4.4: alpha has 1.1-4.4.0.1
    libxml-parser-perl 2.26-1: alpha has 2.26-1.0.1
    lsof 4.43-1: alpha has 4.43-1.0.1
    gaby 1.9.6-0.1: alpha has 1.9.6-0.1.1
    binutils-m68k-linux 2.9.1.0.12-1: alpha has 2.9.1.0.12-1.0.1
    libdbi-perl 1.12-1: alpha has 1.12-1.0.1
    gedit 0.5.3-1: alpha has 0.5.3-1.0.1

    altgcc 2.7.2.2-3.4: sparc has 1:2.7.2.2-3.4.1
    libmime-base64-perl 2.11-2: sparc has 2.11-2.0.1

    ncftp2 1:2.4.3-2: powerpc has 1:2.4.3-2.0.1

Cheers,
aj

-- 
Anthony Towns <aj@humbug.org.au> <http://azure.humbug.org.au/~aj/>
I don't speak for anyone save myself. PGP encrypted mail preferred.

 ``The thing is: trying to be too generic is EVIL. It's stupid, it 
        results in slower code, and it results in more bugs.''
                                        -- Linus Torvalds

Attachment: pgp7b9LLe1MnJ.pgp
Description: PGP signature


Reply to: