[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: PostgreSQL 6.5.2-0 packages for testing

On Sat, Oct 09, 1999 at 08:11:39AM +0100, Oliver Elphick wrote:
> Craig Sanders wrote:
>   >On Fri, Oct 08, 1999 at 11:32:01PM +0100, Oliver Elphick wrote:
>   >> I have now prepared an experimental release of PostgreSQL 6.5.2.
>  ...
>   >> Those who would like to assist in testing may download the new packages
>   >> from www.debian.org/~elphick/postgresql/
>   >
>   >i just downloaded and installed the new postgres packages. postmaster
>   >fails to start, claiming that another postmaster might already be
>   >running (it isn't).
> Thanks for your input, Craig.  6.5.2-0.1 is now available at 
> www.debian.org/~elphick/postgresql, and addresses the two issues you raised.

two problems with this pre-release....

1.  looks like you forgot to include the /var/run/postgresql directory in
the package (or create it in the init.d script).

# dpkg -iGROEB *.deb
Setting up postgresql (6.5.2-0.1) ...
chown: /var/run/postgresql: No such file or directory
dpkg: error processing postgresql (--install):
 subprocess post-installation script returned error exit status 1

this also causes the following packages to fail config.

fixed by:

# mkdir /var/run/postgresql
# dpkg --configure --pending

2.  postgresql-client still doesn't want to install.  problems in the pre-rm

# dpkg -i postgresql-client_6.5.2-0.1_i386.deb 
(Reading database ... 73889 files and directories currently installed.)
Preparing to replace postgresql-client 6.5.2-0 (using
postgresql-client_6.5.2-0.1_i386.deb) ...
dpkg (subprocess): unable to execute old pre-removal script: Exec format
dpkg: warning - old pre-removal script returned error exit status 2
dpkg - trying script from the new package instead ...
dpkg (subprocess): unable to execute new pre-removal script: Exec format
dpkg: error processing postgresql-client_6.5.2-0.1_i386.deb (--install):
 subprocess new pre-removal script returned error exit status 2
Errors were encountered while processing:

fixed by:

# vi /var/lib/dpkg/info/postgresql-client.prerm 
  add "#! /bin/sh" as first line.
# dpkg -i postgresql-client_6.5.2-0.1_i386.deb 


craig sanders

Reply to: