[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: perl dependancy problem

On Tue, Oct 05, 1999 at 10:27:00PM -0700, Joey Hess wrote:
> What am I supposed to do? I could make debconf depend on perl-5.005, but it
> really works with any version of perl 5. Also, if only perl-5.004-base,
> perl-5.005, and perl-5.005-base were installed, and the alternatives pointed
> /usr/bin/perl to perl 5.004, then it would still fail! I realize that would
> require manual intervention to change the alternattives priorities, but it
> still worries me.

If you want debconf to work before the perl packages get fixed you could
do something like (maybe use a different use statement):

eval 'perl -e "use POSIX" 2>/dev/null && exec /usr/bin/perl -S $0 ${1+"$@"}'
	if $running_under_binsh;
eval 'exec /usr/bin/perl5.004 -S $0 ${1+"$@"}'
	if $running_under_binsh;


Reply to: