[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: shlib-with-non-pic-code _libglademodule.so

On Fri, Oct 01, 1999 at 11:23:00AM +0200, Torsten Landschoff wrote:
> I am the maintainer of python-gnome and the associated modules. The
> current python-glade has support for the libglade library in
> _libglademodule.so.  Problem: Lintian complains that _libglademodule.so
> contains position dependent code. But it is compiled with
> gcc -g -O2 -fPIC -c libglademodule.c
> gcc -shared -lc -o _libglademodule.so libglademodule.o -lglade -lxml -lz \
>     -lgtk -lgdk -rdynamic -lgmodule -lglib -ldl -lXi -lXext -lX11 -lm
> (I removed some of the uninteresting options as -Lfoo and -Ibar)
> Could you tell me what I am doing wrong? I don't see anything wrong in 
> that gcc commands. Perhaps lintian is wrong?

I think so, too. I have experienced this error several times, and could
not find any error in the .so files it said were wrong. The bug report
is already filed, #46186.

BTW does this perhaps happen on just this one library in the package?

enJoy -*/\*- don't even try to pronounce my first name

Reply to: