[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

The standard system is inconsistent => overrides problems

[ Reply to set on debian-devel only ]

Hi everybody,

today I built a fake status file as if all packages of priority
standard or higher were installed, and I runned apt-get with this
status file and found that the system was inconsistent, here are the
problems (apt-get check output) :

~/debian-cd/perso@p200$ ./apt-selection check
Reading Package Lists... Done
Building Dependency Tree... Done
You might want to run `apt-get -f install' to correct these.
Sorry, but the following packages have unmet dependencies:
  libpam0g: Depends: libpam-runtime but it is not installed
  lsof-2.2: Conflicts: lsof
            Conflicts: lsof-2.0.35 but 4.37-3 is installed
            Conflicts: lsof-2.0.36 but 4.43-1 is installed
  g++: Depends: libstdc++2.9-glibc2.1-dev (>= 2.91.66) but it is not installed
  lsof-2.0.35: Conflicts: lsof
  lsof-2.0.36: Conflicts: lsof
               Conflicts: lsof-2.0.35 but 4.37-3 is installed
  perl-5.004-doc: Conflicts: perl-doc
  perl-5.005-base: Conflicts: perl but 5.004.05-1 is installed
  ppp-pam: Depends: ppp (= 2.3.7-4) but it is not installed
  netstd: PreDepends: ncurses3.4 but it is not installed
  perl-5.005-doc: Conflicts: perl-doc
  man-db: Depends: libdb2 (>= 2.3.16) but it is not installed
E: Unmet dependencies. Try using -f.

Here are my conclusions :

- ppp-pam is standard and depends on ppp which is optional. ppp
  must be standard or ppp-pam must be optional ...
- netstd must be rebuilt with a new ncurses (libncurses4)
- perl (the fake package) must be of priority extra (the same
  applies for all fake packages)
- perl-5.005-doc must be standard and perl-5.004-doc extra
- something similar for lsof-*, only one of them must be
  standard (the 2.2 one I suppose), the other are extras.
- libpam0g (standard) depends on libpam-runtime (optional),
  libpam-runtime must be standard
- man-db may be built with the db2 from glibc2.1 (-ldb) instead 
  of libdb2
- g++ should only recommend libstdc++2.9-glibc2.1-dev as does gcc

Thank you for correcting what's needed (I won't file bug reports
unless someone ask me to do so for a particular package).

A standard system which is consistent is far better ! I've discovered
this problem while trying to run apt-get on a 100% standard system
to see the dependencies that need to be installed for each package.


PS: apt-selection is not a standard program, it's a litlle wrapper script
    I wrote.
Hertzog Raphaël >> 0C4CABF1 >> http://prope.insa-lyon.fr/~rhertzog/

Reply to: