[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: ITP: stalin - it's now GPLed.

On Sun, May 30, 1999 at 08:00:23PM +0200, Marcus Brinkmann wrote:
> You are most likely wrong. Under the Hurd, I get sometimes:
> Depends: libc0.2, libc0.2 (>= 2.1)
> which is fine.

It may have no ill effects, but it isn't fine.  To me that indicates that
something is broken somewhere and should be fixed before it hits us where it
really matters.  I cannot reproduce this, though (I haven't got any
duplicate depends).

> Maybe those come from /etc/dpkg/shlibs.default (for example
> for libm.so.6)

At least my libc6 has a shlibs entry for both libc and libm, requiring >=
2.1. And the default shlibs file does not offer any other sources for libc6.
If dpkg-slibdeps is pulling the plain libc6 entry from
/etc/dpkg/shlibs.default, then something is broken.

%%% Antti-Juhani Kaijanaho % gaia@iki.fi % http://www.iki.fi/gaia/ %%%

   "... memory leaks are quite acceptable in many applications ..."
    (Bjarne Stroustrup, The Design and Evolution of C++, page 220)

Reply to: