[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Please comment on new acct package for 2.2.* kernels

GNU acct, compiled under kernel 2.0.*, would not run correctly under kernel
2.2.* due to a change in acct.h. This had long been reported, and forwarded
upstream. No solution had been provided, though.

As I now have a box running 2.2.7, I have built a new package which installs
properly under kernels 2.2.* and 2.0.*. It uses a simple perl script,
installed in /usr/sbin, to test the running kernel version from postinst and
init.d.  The postinst warns about the mismatch between package and kernel if
2.2 is not found and mentions the slink package as an alternative for 2.0.*:

sonny:/home/edd/debian [root] # dpkg -i acct_6.3.5-9_i386.deb 
(Reading database ... 51573 files and directories currently installed.)
Preparing to replace acct 6.3.5-8 (using acct_6.3.5-9_i386.deb) ...
Skipping process accounting as the installed package requires kernel 2.2.*.
Unpacking replacement acct ...
Setting up acct (6.3.5-9) ...
Installing new version of config file /etc/init.d/acct ...
  Please note that this version of the GNU acct utilities requires a kernel
  from the 2.2 series, or later. An otherwise identical version of GNU acct 
  which is suitable for 2.0 kernels can be found in Debian 2.0 aka 'slink'.
Update-menus: waiting for dpkg to finish(forking to background)
Update-menus: (checking /var/lib/dpkg/lock)
Skipping process accounting: Package requires kernel 2.2.*.

The /etc/init.d/acct script states that acct has not been started/stopped. 
Simply informing the sysadmin appears as an appropriate course of action.

Is this ok with everybody ? Are there other suggestions ?

I have put the package into ~edd on master and would appreciate comments. If
I don't hear anything, I will upload the package into the archive in the next 
few days.

According to the latest figures, 43% of all statistics are totally worthless.

Reply to: