[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: intent of package seti@home

I have been running the i386.glibc2.0.46 version of seti@home on and
off now for a few weeks.  I have not had any of the problems you
mentioned.  I am running it as a non-privilged user in it's own
account.  I have used it with and without the setiview program with
equal luck.  I am running slink, with kernel 2.0.34, glibc2.  

The only problem I did have was that I am not using diald, so I must
connect to my isp manually.  I found that I could stop the seti program
and restart it (or shut down the computer for that matter) and when
restarted the seti@home program would 'pick up where it left off'. 
HOWEVER when it reached %100 done and attempted to contact the server I
was not logged in.  It printed the message 'will retry in an hour'.  So
I killed the program, brought up pppd, and then restarted the program. 
It connected to the server and then proceded to download another work
unit WITHOUT first uploadeding the completed unit (not enough time
elapased for that, the modem lights did not wink write long enough, and
a look at the directories showed no save of the old work units).  I
have filed a bug report with seti@home.

>I tried this since, being a member of the Planetary >Society, I
>wait for your package.  However, I ran into some >problems.

>Running kernel 2.0.35 with glibc2.1 on potato, which >seemed to work
>fine for everything else, I started getting kernel >oops and core
>all over the place.  I tried both the gnulibc2 and >static versions
>the both had this problem.  After a reboot (there were >a half a dozen
>before I sorted this out, at least two locked up the >machine tight)
>things were stable again until I launched the >setiathome client (as
>unprivileged user) then the problems started again.

>Rather than trying to debug an old kernel, I upgraded >to kernel 2.2.5
>night before last and the problems seemed to have >stopped.  This may
>kernel 2.2.x for some reason (maybe not because they >built it that
>but due to some horribly nasty bug that the old >kernels can't cope
>BTW, the oops were in memory management, one for >example was "Unable
>handle kernel paging request".

Please consider testing on 2.0.x kernels to see if it will run OK for
others (in case it's just me :) ) or indicating in the LSM description
that it may need a 2.2.x kernel.

Anyone else thinking of running this: you've been warned! :-)

Addendum: checking the messages file, I'm still getting Oops, but at
least the machine's not crashing.  This may be unrelated though since
I'm running dselect and gzip's barfing on libc6-pic which is broken.
I need to file a bug against libc6-pic.


Amateur Radio, when all else fails!


Debian Gnu Linux, Live Free or .....

Do You Yahoo!?
Get your free @yahoo.com address at http://mail.yahoo.com

Reply to: