[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Problems with pgp and gpg

Hi. I'm having problems with the permitions for using pgp and gpg. It's 
diferent symptoms but the problem it's the same (I think). Let me explain
the problem:

With pgp:
When I try to make my own .deb packages, using 'build -rfakeroot', the script
breaks when running pgp with this error:

---begin quote---
Enter pass phrase: cannot open tty, using stdin

Unable to get terminal characteristics: ioctl: Inappropriate ioctl for device
---end quote---

If I try to run the build script under root ('su root', then 'build'), it
runs smoothly (I've copyed my ~/.pgp dir to /root/.pgp just to try this out).

On the other hand, If I try to run pgp by itself (using 'pgp -sa ...' or
whathever), it runs great. Why does it run  if called directly, but breaks if
called under the build script? Some problem with this script?

With gpg:
Well, with gpg the problem goes like this: If I run it under my account,
it doesn't matter if it's called in the command line or from the build script,
it breaks right away with the following error:

---begin quote---
gpg: fatal: cannot open /dev/tty: Permission denied
secmem usage: 0/0 bytes in 0/0 blocks of pool 0/16384
---end quote---

But if I run under root, everything goes well. This one seems like a problem
with the permitions.

So, the problem goes like this: I think the problem has something to do with
the /dev/tty permitions, but if I'm right, why can I run pgp? And the big
question is, how can I solve this?

BTW, I'm running kernel 2.2.2-ac4, and I think maybe this has something to do
with it, because the last time I've used pgp, about 6/7 months ago (I didn't
need it so... ;-)), I was running 2.0.x, and everything went smoothly.
If needed, I can send you the /dev listing.

Pedro Guerreiro
Diplomacy: the art of letting someone have your own way.

Reply to: