[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: perl version depends

On Thu, 8 Oct 1998, Richard Braakman wrote:

dark>That "only" is a large source of packaging bugs.  In fact, the (IMO)
dark>most annoying upgrade problem in hamm was a pathname problem: two
dark>packages had moved to a different directory at the last minute, and
dark>the auto upgrade script hadn't been modified to match.
	Also some complicated packages have perl paths hardwired in
relatively obscure places (eg pdl) , and these may not show up
immediatley. I agree that there is a good possibility that releasing slink
with half a perl upgrade could be a disaster.
	If we set a policy on the paths within a day or two and then have,
say three weeks, and can count on people working hard, and allowing NMU's,
we can probably get the critical packages fixed (I don't know what they
are).  But doing it all in 7 days is not a good idea.

	Re: installing in /usr/lib/perl5/debian .  I have an uneasy
feeling about it, but no concrete objections.  My guess is that Darrin has
a better idea about it than me.  It may be ok, I'll follow it if its set.
	Just to summarize, I think we have to either go back to 5.004 , or
push the freeze back a couple of weeks.


John Lapeyre <lapeyre@physics.arizona.edu>
Tucson,AZ     http://www.physics.arizona.edu/~lapeyre

Reply to: