[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: problem w/ the Java interface lib for PostgreSQL



libpgjava depends on jdk1.1-runtime (>= 1.1.3.v2-1)
jdk1.1 conflicts with jdk1.1-runtime                                           
jdk1.1 provides jdk1.1-runtime

jdk1.1-dev depends on jdk1.1 (= 1.1.6v4a-3)

So I cant install libpgjava w/ losing the -dev.

On 05-Oct-98 Stephen Zander wrote:
>>>>>> "Shaleh" == Shaleh  <shaleh@livenet.net> writes:
> 
>     Shaleh> libpgjava depends on jdk1.1-runtime (>= ??.??).
>     Shaleh> jdk1.1-dev provides jdk-runtime.  However the dependency
>     Shaleh> resolution tries to install jdk1.1-runtime because of the
>     Shaleh> versioned depends and jdk-runtime removes jdk-dev.  So if
>     Shaleh> I install libpgjava, I lose the java compiler and what
>     Shaleh> not, which means I cant write apps using java and was the
>     Shaleh> point of wanting the java lib.
> 
> Eh? jdk1.1 /conflicts/replaces/provides jdk1.1-runtime, not
> jdk1.1-dev, at least that's they way I specified it.
> 
> The obvious answer is file a bug against libpgjava :/
> 
> 
> -- 
> Stephen
> ---
> Perl is really designed more for the guys that will hack Perl at least
> 20 minutes a day for the rest of their career.  TCL/Python is more a
> "20 minutes a week", and VB is probably in that "20 minutes a month"
> group. :) -- Randal Schwartz
> 
> 
> --  
> To UNSUBSCRIBE, email to debian-devel-request@lists.debian.org
> with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org

----------------------------------
E-Mail: Shaleh <shaleh@livenet.net>
Date: 05-Oct-98
Time: 14:45:23

This message was sent by XFMail
----------------------------------


Reply to: