[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

virtual package for apache required?

Please lets discusse whether we need a virtual package for apache and

The problem is the following:

apache and apache-ssl share some common files like htpasswd or
mod_perl. As of this until now apache-ssl had to conflict with
apache. But since some people want to run apache and apache-ssl, and
some packages (as php) depend on apache, there is a problem.

With the newest release of apache-ssl I built a new package
apache-common, which has all the files which are common to apache and

apache-ssl depends now on apache or apache-common as long as apache
don't use the same scheme. apache-ssl also provides apache for the
dependent packages to work. BUT apache-common would normaly have to
conflict with apache because of the common files, but it can't now,
because it would then conflict with the provide apache of apache-ssl.

I propose the following:

apache and apache-ssl should both depend on the apache-common and
provide apache-virtual (or else) and the other packages (as php) could
then depend on it.

Christoph Martin

Christoph Martin, Uni-Mainz, Germany
 Internet-Mail:  Christoph.Martin@Uni-Mainz.DE
--------------export-a-crypto-system-sig -RSA-3-lines-PERL------------------
#!/usr/bin/perl -sp0777i<X+d*lMLa^*lN%0]dsXx++lMlN/dsM0<j]dsj
$/=unpack('H*',$_);$_=`echo 16dio\U$k"SK$/SM$n\EsN0p[lN*1
#what's this? see http://www.dcs.ex.ac.uk/~aba/rsa/

To UNSUBSCRIBE, email to debian-devel-request@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org

Reply to: