[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Configuration of teTeX broken (send once more due to list problems)

On 12 May 1998, Olaf Weber wrote:

> It would probably take some changes to the sources of texconfig to
> enable you to use symlinks for texmf.cnf and mktex.cnf into an
> etc/texmf directory.  It takes some fiddling with the original sources
> to make those symlinks unneccesary.
I consider it to be only helpful in finding the files when you do
    ln -s /usr/lib/texmf/web2c/texmf.cnf /etc/texmf/texmf.cnf
No changes in any sources are needed.  The drawback of this quick and
dirty hack is that you can't mount /usr readonly because the real
location of the configuration files is there.  Only putting the real
file to /etc/texmf could require some changes (but I don't know why
because I can't think that texconfig or other programs check, whether
/usr/lib/texmf/web2c/texmf.cnf is a real file or only a symlink to
/etc/texmf/texmf.cnf).  I've done the link in the way above to avoid
confusing dpkg.
> You might make texmf/web2c itself a symlink to /etc/texmf, but note
> that this directory might contain largish files which IMHO are not
> conffiles.  The letter of the law might insist on those being moved to
> a /var/texmf/web2c directory.
Sure this would be a bad solution.  Why we don't go the way of the old
teTeX-0.4 packages???
> And please do note that the files in /usr/local/lib/texmf _must_ be
> contained in a TDS-conforming structure.  That is, metafont won't be
> able to find
> 	/usr/local/lib/texmf/mf/foo.mf
> but would find e.g.,
> 	/usr/local/lib/texmf/fonts/source/local/foo/foo.mf
May be that this was the reason, now my Metafont sources where found.
But why Metafont has found them under teTeX-0.4??? I didn't change
anything but the teTeX package and no local files whether TEXINPUTS
or MFINPUTS where found.
> I do not understand the workaround: it doesn't match the situation you
> described above, with a /usr/local/lib/texmf tree.  In any case, the
No, it only gives me the chance to get the letter I had to write
read :-).  I never said, that this would be the solution...

> For example, an additional latex style file _has_ to be in
> 	/usr/local/lib/texmf/tex/latex
> or a subdirectory if it is to be found.
May be that teTeX 0.9 is more strict in following the TDS and enforces
the user to stay at this.  Now it works for me.

Thanks for the help so far.  According to a mail of the package maintainer
I hope that the config file problem will be solved soon.



To UNSUBSCRIBE, email to debian-devel-request@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org

Reply to: