[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Dependencies problem


my package ncpfs provides a shared library (libncp). When trying to
build using dpkg-buildpackage, debstd gives several errors about not
being able to find dependencies for the binaries in the package. The
problem goes away if I provide a shlibs.local file like this:

libncp  1       ncpfs (>= 2.0.11-6)

However, if I do this the dependencies of my packages will be:

Depends: ipx, libc6, libcomerr2, ncpfs (>= 2.0.11-6)

Is this right, a package that depends on itself? How can remedy this
situation? The package installs fine, though...

Thanks in advance.



Eloy A. Paris
Information Technology Department
Rockwell Automation Venezuela
Telephone: +58-2-9432311 Fax: +58-2-9431645

To UNSUBSCRIBE, email to debian-devel-request@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org

Reply to: