[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Debian Bug#20445 disagree

On Thursday, April 9, 1998, Brian White <bcwhite@verisim.com>
> I think that if somebody can get the 2.2 kernel source off of CD, build
> the kernel (hopefully as a debian package) and install it, they have the
> knowledge and the ability to download packages from the network using
> one of the many possibilities of dpkg, dselect, dftp, or another.
> What we lose is including packages that break either during installation or
> when run on a stock Hamm system.  Since we are shipping a "hamm" CD, I
> believe that that CD should be as problem free as possible.  If people
> start mixing things from different CDs, they have to realize things may
> not work "out of the box".

I must have missed the part of this conversation that had the facts in
it... Exactly what 2.1.x-kernel-ready packages currently in hamm break
parts of a 2.0.x system?

For example, if modutils 2.1.71 works perfectly fine with 2.0.x kernels,
and there are no outstanding bug reports against it related to that (a
quick glance says there aren't), then there's no reason to go back to the
2.0.0 version.

2.0.x is our release priority - however I think having hamm ready
for 2.2 kernels *without causing problems for 2.0.x users* is a good idea.
Debian does have a bit of a reputation for packaging all the latest and
greatest stuff.

The original bug report mentioned these packages:


* Juan Cespedes mentioned that romfs works with 2.0.x with the
  included patches. In any case it does not hinder 2.0.x functionality.
  *crosses off list*
* ax25-utils doesn't hinder 2.0.x functionality, and patches are
  available. *crosses off list*
* pciutils doesn't hinder 2.0.x functionality. *crosses off list*
* vold doesn't hinder 2.0.x functionality. *crosses off list*
* ipportfw doesn't hinder 2.0.x functionality and has a supplied 2.0.x
  patch. *crosses off list*
* bridgex doesn't hinder 2.0.x functionality and has a supplied 2.0.x
  patch. *crosses off list*

That leaves us with smbfs/smbfsx and ncpfs/ncpfsx. Can someone verify that
these packages coexist or that smbfsx/ncpfsx works with 2.0.x?

I personally think non-interactively printing a message during
installation like "Warning - this package requires a 2.1.<blah> or later
kernel to function." would be more than adequate.
Robert Woodcock - rcw@oz.net
All I want is a warm bed and a kind word and unlimited power.
		-- Ashleigh Brilliant

To UNSUBSCRIBE, email to debian-devel-request@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org

Reply to: