[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Essential pacakges

I have a problem, was just testing some code out and this interesting
thing came up:

Package: e2compr
Version: 1.06-2
Priority: extra
Section: utils
Essential: yes
Maintainer: Tom Lees <tom@lpsg.demon.co.uk>
Pre-Depends: libc5 (>= 5.4.0-0)
Conflicts: e2fsprogs
Provides: e2fsprogs
Replaces: e2fsprogs   

Now, my understanding is that essential packages, by definition, must
be installed for the system to function - This package claims to be
essential but removes other essential packages! (thus an essential package
does not have to be installed for the system to function)

This is going to cause me grief, should this be allowed or is this package
in serious viloation of policy?


E-mail the word "unsubscribe" to debian-devel-request@lists.debian.org
TO UNSUBSCRIBE FROM THIS MAILING LIST. Trouble?  E-mail to listmaster@debian.org .

Reply to: