[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: hamm upgrade using dselect

Guy Maor <maor@ece.utexas.edu> writes:

> Sven Rudolph <sr1@os.inf.tu-dresden.de> writes:
> > I just took a 1.3.1 box and configured dselect to upgrade. The
> > conflicts (reordered and commented)
> It looks like you use the dpkg-ftp backend?  That backend *DOES* *NOT*
> handle predependencies correctly with dpkg --predep-package.

(As mentioned above I used the "mounted" backend.) I think the error is
in `dpkg --predep-package'. Look at this transcript again:

Looking for part 1 of libc6 ... /home/debian/ftp/debian/dists/unstable/main/bina
Running dpkg -iB for libc6 ...
dpkg: regarding .../base/libc6_2.0.7pre1-1.deb containing libc6:
 libc6 conflicts with libc5 (<< 5.4.33-7)
  libc5 (version 5.4.33-6) is installed.
dpkg: error processing /home/debian/ftp/debian/dists/unstable/main/binary-i386/b
ase/libc6_2.0.7pre1-1.deb (--install):
 conflicting packages - not installing libc6
Errors were encountered while processing:

The backend asks `dpkg --predep-package' about the next steps. The
answer is that libc6 is to be installed. But `dpkg --predep-package'
didn't see that this cannot be done unless libc5 is upgraded.

Sven Rudolph <sr1@inf.tu-dresden.de>

TO UNSUBSCRIBE FROM THIS MAILING LIST: e-mail the word "unsubscribe" to
debian-devel-request@lists.debian.org . 
Trouble?  e-mail to templin@bucknell.edu .

Reply to: