[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: libfoo package depend on libfoog package?

On Fri, 12 Sep 1997, Scott K. Ellis wrote:

> Perhaps.  However, we have provided sufficient documentation on the
> process of installing new stuff from hamm, if you haven't read it already,
> check out <http://www.gate.net/~storm/FAQ/libc5-libc6-Mini-HOWTO.html>,
> which is a description of the minimum packages to install to get stuff
> from hamm to work.  This includes the new ld.so.  I post a text version of
> it here about once a week, and it is in our archive as well.  It seems
> like a lot of work to add dependancys for everything that can be fixed
> by RTFMing.

Oh, _I_ have read it every week since you started posting that, and even
sent you some addenda, but it's not _me_ who will have the problem (I
upgrade my development system twice a week, to keep track of unstable).

A user that doesn't want to upgrade his system to libc6, just upgrade 
a single libc5-based library to another libc5-based version, only has to
add /usr/lib/libc5-compat, /usr/X11R6/lib/libc5-compat and /lib/libc5-compat 
to his /etc/ld.so.conf to keep having a libc5 system, but using the 
libc5-based libs from hamm. Am I wrong?

I have just checked and couldn't find which postinst will add those lines 
when upgrading from bo to hamm (I thought it was ldso's one, but it
seems I was wrong), so it would be nice if that was suggested somewhere,
perhaps in your mini-Howto.

Enrique Zanardi					ezanardi@noah.dfis.ull.es
Dpto. Fisica Fundamental y Experimental
Univ. de La Laguna

TO UNSUBSCRIBE FROM THIS MAILING LIST: e-mail the word "unsubscribe" to
debian-devel-request@lists.debian.org . 
Trouble?  e-mail to templin@bucknell.edu .

Reply to: