[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

gcc problem

I've installed gcc- on my system (because I have gcc- for SCO
and do crosscompilation). Everything was fine, until I tried to compile a
program for our firewall. Both systems do have the same setup (kernel
2.0.30, libc 5.4.23 etc) except that the firewall has barely more packages
than the boot disks offer. In particular all packages on the firewall are

However, compiling with gcc- gives me a binary that's differently
linked against libc. ldd says:

	libc.so.5 => /lib/libc.so.5 (0x40010000)

instead of the usual:

	libc.so.5 => /lib/libc.so.5

What does this mean? It appears that I can use both versions on my
workstation, but only the latter works on the firewall.

I tried several things and found out that the binary on my machine works
just because iBCS is loaded. The kernel cannot execute it.

Any idea what to do (I'd like to keep working with ?

Michael Meskes, Projekt-Manager      | meskes@topsystem.de, meskes@debian.org
topsystem Systemhaus GmbH            | Phone: (+49) 2405/4670-44
Europark A2, Adenauerstr. 20         | Fax:   (+49) 2405/4670-10
52146 Wuerselen                      | Go SF 49ers! Use Debian GNU/Linux!

Reply to: