[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: SOLVED: Erk! Something is *really* wrong here!


Karl Ferguson, in an immanent manifestation of deity, wrote:
>At 05:30 PM 3/3/97 +0100, Miquel van Smoorenburg wrote:
>>Just copy your wtmp file to wtmp.old or so, and truncate (not delete) the
>>original one using ": > /var/log/wtmp" when this happens again.

Well, I noticed that I was having this problem as well.  So, I said
"Fine, I've got time for this."  Found out that when I added more disk
or something, I had turned /var/adm into a directory rather than a
symlink.  So, I ran savelog correctly on the wtmp.  Well, here's the
current output of last:
jean     ttyp7        eskimo.com       Mon Mar  3 18:43 - 18:47  (00:03)
armadilo ttyp6        beauty.gmu.edu   Mon Mar  3 17:58 - 18:56  (00:57)
*******              ****
z*3         Mon Mar  3 17:25   still logged in
dhummer  ftp          reqd-110.ucdavis Mon Mar  3 17:11 - 17:16  (00:04)

wtmp begins Mon Mar  3 17:11:41 1997

Truncating wtmp every six hours doesn't sound like a real good solution.

Note that I'm still running the 2.0.23+SYN kernel:
Linux perv 2.0.23 #11 Tue Oct 22 00:24:15 PDT 1996 i486 unknown

But I am following bo pretty closely.  The only things I've got that
aren't in unstable are sendmail, perl, wu-ftpd and apache.

Whether or not this is the problem, here's some output for grits and
ii  base            1.1.0-14       Debian Base System Miscellaneous Files
ii  bash            2.0-2          The GNU Bourne Again SHell
ii  cron            3.0pl1-34      management of regular background processing
ii  libc5           5.4.23-2       The Linux C library version 5 (run-time libr
ii  netstd          2.12-1         Networking binaries and daemons for Linux
ii  screen          3.7.2-2        A screen manager with VT100/ANSI terminal em
ii  sysvinit        2.70-1         System-V like init.
ii  xbase           3.2-3          Local clients and configuration required by 

>Ok, I've just done this.  However, would this have any relation to the utmp
>corrupting outputs of 'w' and 'who' as well?

Haven't had any corrupted 'w' or 'who'.  The only corruption I've seen
is visible using last.

- -- 
<torin@daft.com> <http://www.daft.com/~torin> <torin@debian.org> <torin@io.com>
Darren Stalder/2608 Second Ave, @282/Seattle, WA 98121-1212/USA/+1-800-921-4996
@ Do you have your clothes on? I probably don't. Take yours off. Feel better. @
@ Sysadmin, webweaver, postmaster for hire.  C/Perl/CGI programmer and tutor. @

Version: 2.6.2
Comment: Processed by Mailcrypt 3.4, an Emacs/PGP interface


Reply to: