[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Debian install problems

I have not performed a full Debian installation since I first used Debian
with version 1.1.

It seems that a lot of things have been broken with version 1.2!

These problems *must* be fixed by version 1.3!

I'll try to go through the problems in order.

First, the installation instructions included are very out-of-date.  For
instance, they mention that you will have to wait because it will try to
check the CD-ROM for the base system and it will fail.  This is not good.

Finally, haven written resq1440.bin and root.bin to disk (turns out that
root.bin was useless), I rebooted from the disk.  Turns out that the
kernel on the disk detected a Sony CDU-535 in the computer, even though
there is *no* Sony CD-ROM present!  (It is a SCSI CD-ROM hooked up to an
Adaptec controller)  This caused the computer to lock up.  I eventually
solved it by passing "linux cdu535=0x2c0" to the boot kernel to tell it a
port not in use.  Then the driver finally knew that there was not a Sony
CD-ROM in there.

Then everything went fairly smoothly until it came time to install the
base system.  It claimed to be scanning for files.  Turned out that it
didn't see the CD-ROM.  I finally figured out that maybe I should switch
to the shell and mount it myself.  Surprise!  /dev/scd0 was missing.  And
MAKEDEV is dreadfully broken.  So I had to run over to a machine down the
hall and telnet to a Linux box to find out the values, run mknod, and
mount the CD to /cdrom.  So far so good.  Rerun "install base system"
option.  Again it didn't see the CDROM.  Finally, I determined that it was
looking for the tgz file in a subdirectory right off root, while the file
on the cdrom was at /cdrom/disks-i386/current or some such.  OK fine, so I
made a link from /var/filename to /cdrom/disks-i386/current/filename.
Then it agreed to install the base system off the CD-ROM.  Whew!

There is no reason that anybody should have to go through all this just to
get it to see a SCSI CD-ROM!  A SCSI CDROM is a VERY standard item!

Now, on to the modules.  Seems that it doesn't even scan the CD-ROM for
this.  I went to the shell and tried to run dd to copy the stuff to a
spare floppy.  No dd on the system.  "cat filename.xxx > /dev/fd0" worked.
Switch back to tty1, install drivers.

OK, reboot.

Log in, start dselect, etc, etc, etc.  Have to recreate a device name in
/dev since scd0 is again missing and MAKEDEV is again broken, have to use
mknod again.  Select packages, pick install, configure, etc, etc...

Reboot again to make sure it was OK.

But surprise!  Network doesn't work.  I verified that it was eventually
configured **EXACTLY** like the RedHat system was prior to installing

The network card is a plain NE2000 card.  Additionally, the route program
locked up whenever I tried to run it to see what the routing table was.
Had to interrupt it with Ctrl-C.

Basically, it refuses to speak with anything other than x.x.10.0 through
x.x.10.6 machines in the network, and even those, just barely.  It won't
even talk to the nameserver at x.x.10.21 or the gateway at x.x.1.3.

Played around with it for hours.  Still no go.  Had others look at it.
They were mystified.

As I speak, I am compiling a kernel for it on the theory that the hords of
unneeded and possibly conflicting devices in the default kernel are
causing problems.

With the system of modules, there is no need for all those devices in the
default kernel.  The kernel should be as bare as possible, NOT using
multiple intrusive probes that mess up other hardware.  Let the users
enable modules as neccessary.  (As, for instance, is done in RedHat).

John Goerzen          | Running Debian GNU/Linux (www.debian.org)
Custom Programming    | 
jgoerzen@complete.org | 

Reply to: