[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

downgrad libc OK with unstable deps!!!

Maybe this is OK, but I just don't understand this.
On my system, I have mostly unstable packages installed, that
depend on libc5_5.4.17. But when I do

# dpkg -i libc5_5.4.13-1.deb
dpkg - warning: downgrading libc5 from 5.4.17-1 to 5.4.13-1.
(Reading database ... 35402 files and directories currently installed.)
Preparing to replace libc5 5.4.17-1 (using libc5_5.4.13-1.deb) ...
Unpacking replacement libc5 ...
Setting up libc5 (5.4.13-1) ...

dpkg only warns, it doesn't shout. I would have expected it to
shout about, for example, this dependancy:

$ dpkg -s xfig
Package: xfig
Status: install ok installed
Priority: optional
Section: graphics
Installed-Size: 819
Maintainer: joost witteveen <joostje@debian.org>
Version: 3.1.4b-5
Depends: elf-x11r6lib, libc5 (>= 5.4.17-1), libjpeg6a, xlib6 (>= 3.2-0)

(and I'm going to fix that dependancy right now, it shouldn't need the
libc5 from bo).

Does this reproduce on other people's systems, or is there something
wrong with my setup?

joost witteveen
Use Debian/GNU Linux!

TO UNSUBSCRIBE FROM THIS MAILING LIST: e-mail the word "unsubscribe" to
debian-devel-REQUEST@lists.debian.org . Trouble? e-mail to Bruce@Pixar.com

Reply to: