[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

libc5 dependency change proposal

I submitted the following bug report against libc5. This might need
Subject: libc5 5.4.13-1 : .shlibs file problem
Package: libc5
Version: 5.4.13-1

The shlibs file for libc5 contains:

libc    5       libc5 (>= 5.4.13-1)
libm    5       libc5 (>= 5.4.13-1)
libpthreads 1   pthreads1

This indicates for all program linked with the libc 5.4.13 that they will   
not be able to be installed with prior version of 5.4.X!    

I think the shlibs file should at least look like this:

libc    5       libc5 (>= 5.4.0-0)
libm    5       libc5 (>= 5.4.0-0) 
libpthreads 1   pthreads1

This would allow up and downgrading within the 5.4.X version of the libc
which is highly to be desired.

Or simply (assuming that 5.4.X is compatible with 5.2.X which is mostly

libc    5       libc5
libm    5       libc5
libphtreads 1   pthreads1

The last construction would allow installing debian 1.2 packages under
debian 1.1. Might be controversial      

Perhaps the package maintainer could override the last form if he knows
there is a dependancy on changed semantics of 5.4.X.

--- +++ --- +++ --- +++ --- +++ --- +++ --- +++ --- +++ ---
PGP Public Key  =  FB 9B 31 21 04 1E 3A 33  C7 62 2F C0 CD 81 CA B5 

TO UNSUBSCRIBE FROM THIS MAILING LIST: e-mail the word "unsubscribe" to
debian-devel-REQUEST@lists.debian.org . Trouble? e-mail to Bruce@Pixar.com

Reply to: