[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

New pacakge ...


I'm still working on getting this new package done.  I'm trying
to generate the packages using dpkg-buildpackage, but I'm having
trouble.  first I built the binary package by running
debian/rules by hand (just to get it ti work).  I wound up
getting errors from /usr/lib/dpkg/controllib.pl, line 29.

That line now looks like this:

    my ($lhs,,,);

instead of this:

    my $lhs,,,;

I hope this is OK.  Anyway, when I use dpkg-buildpackage to do
the build, I need to do it as root, or it barks.  However, root
does not have a PGP profile at all (and will not), so the
signing stuff fails.  I tried feeding "pgp -u richr" as the pgp
command, but that apparently just looks in roots secret ke file
for user richr (and root doesn't have a secret key ring).
I also tried using -p"su richr -c pgp" which seems like it should
work after having a look at the dpkg-buildpackage script, but it

Anyhow, the binary package builds with a different
md5sum than the one I built from debian/rules by hand.  I have no
idea what to make of this.  your suggestions would be


Richard G. Roberto
011-81-3-3437-7967 - Tokyo, Japan

Bear Stearns is not responsible for any recommendation, solicitation, offer or
agreement or any information about any transaction, customer account or account
activity contained in this communication.

This message was distributed manually by Bruce@debian.org after the list
initially failed to distribute it.

Reply to: